求职
您所在位置:求职指南网 >> 求职就业电脑培训学习网络知识网络基础知识利用路由备份确保线路贯通

利用路由备份确保线路贯通

07-22 16:53:53| http://www.caiwu51.com |网络基础知识|人气:660我要推荐此文给好友

利用路由备份确保线路贯通,本站还有更多网络基础知识,网络基础,计算机网络基础知识,计算机网络知识学习方面的资料。
正文:
  编者按:淮安地税在2M光纤透明线路的基础上,利用Cisco备份发挥原有ISDN网络的作用,从而降低了成本,提高了工作效率。
  
  淮安地税目前有三种类型的网络拓扑结构。首先,部分原有的ISDN线路将继续作为重要的通信手段参与网络构建。这是由于目前省、市两级信息交换较少,ISDN的通信方式仍然能够满足当前需求,另外市区范围内的一些偏远的临时征收点出于成本和业务两方面的考虑,也要求保留原有的ISDN通信方式。
  
  其次,在市区范围内与地税系统外信息的直接交换全部由中心机房负责,市区分局仅负责内部的数据交换,情况比较单一,因此在已拥有的Cisco 2610上增加WIC-1T模块卡和ISDN BRI 模块作为备份即可。
  
  第三,考虑到县局与当地机构联系密切,数据交换频繁、业务复杂,网络变动的可能性较大,对设备的扩展性也要求较高,因此在原有的ISDN 拨号设备Cisco 1603的基础上,增加扩展性较好的Cisco 3640和Cisco 1603作为备份设备,并通过热备份路由协议(HSRP, Hot Standby Routing Protocol)作为Cisco 3640的热备份设备 。
  
  备份方案
  
  Cisco的备份技术包括路由设备备份和线路备份。实际工作中常用的路由设备备份采用HSRP协议,线路备份则包括端口备份、浮动的静态路由以及拨号监控。现根据当前网络的类型进行设置:
  
  在中心机房主干路由器Cisco 7206与Cisco 3640之间和县局主路由器Cisco 3640与Cisco 1603之间进行HSRP的热备份容错。由于HSRP协议配置在E0口,是利用虚拟的IP网关地址来实现的,不会和其他协议发生冲突,可确保中心路由安全、可靠地运行。
  
  由于第一种网络连接类型为ISDN通信方式,考虑其安全性和实际访问情况,采用静态路由协议较为方便。
  
  Cisco公司特有的EIGRP内部网关协议比较适用于在同一网段内有多个路由器共同工作的情况,所以采用EIGRP可以在自身的拓扑结构表中保留两条可以到达目的地的路由路径,一条是当前使用的路由,另外一条为备份路由。这样一旦当前路由失效,EIGRP可以迅速从拓扑结构表中找到备份路由,但采用EIGRP会对整个网络的安全和治理带来一定的难度,需要加强这方面的考虑。
  
  对于第二种连接类型,决定采用端口备份和浮动的静态路由相结合的方法来保证在同时使用动态路由协议的情况下,浮动的静态路由自动发挥作用,使用户不会意识到网络连接曾经存在过故障。
  
  对于第三种连接类型,Cisco 的Dialer Watch技术能够很好地满足这种情况。但Dialer Watch 要求较高,而县局的Cisco 1603 路由器IOS版本为11.1,不能稳定地运行Dialer Watch,所以由市局中心机房采用主动拨号备份的方法来避开版本问题。但同时要注重Dialer Watch在监控一个网络时,只有当此网络的全部路由都失效时,才进行拨号连接,因而在IP地址规划时应充分考虑到这种影响。
  
  路由配置举例
  
  由于篇幅有限,以下仅列举主要的配置语句。
  
  ● Cisco 7206
    interface FastEthernet0/0
    ip address 141.48.16.252 255.255.255.0 
    standby 1 ip 141.48.16.253
    !建立HSRP协议,产生对外虚拟的141.48.16.253 IP网关地址,并设立了优先权,为主动路由器。
    router eigrp 3208
    network 141.48.0.0
    network 171.10.0.0
    no auto-summary
    ! 建立EIGRP路由协议,区域号为3208。
  
    ● 市局的Cisco 3640
    interface FastEthernet2/0
    ip address 141.48.16.254 255.255.255.0
    standby 1 ip 141.48.16.253
    standby 1 priority 110
    !建立HSRP协议,产生对外虚拟的141.48.16.253 IP网关地址,优先级为110,
  大于默认的100,被设为被动路由器。
    interface BRI3/1
    ip address 131.47.126.1 255.255.255.0
    dialer map ip 131.47.126.20 name hads broadcast 5912784
    dialer map ip 171.10.65.0 name hads broadcast 5912784
    !建立监控的网络所需要的ISDN 广播绑定信息。
    dialer watch-group 5
    dialer-group 2
    !拨号监控的组号为5,DDR拨号组号为2。
    ip route 141.16.16.0 255.255.255.0 131.47.99.100
    !到省局的ISDN 静态路由。
    ip route 141.48.86.0 255.255.255.0 131.47.125.130 150
    !响应淮阴区路由器ISDN备份端口浮动的静态路由,权值为150。
    dialer watch-list 5 ip 171.10.65.0 255.255.255.0
    dialer-list 2 protocol ip deny
    ! 对指定的171.10.65.0和255.255.255.0 网段进行监控,同时以默认的时间间隔进行刷新。
   
    ● 分局的Cisco 2610
    interface Serial0/0
    backup delay 3 0
    backup interface BRI0/0
    ip address 171.10.81.2 255.255.255.0
    no fair-queue
    !指定的备份端口为bri0/0。
    interface BRI0/0
    ip address 131.47.125.130 255.255.255.0
    dialer map ip 131.47.125.1 name OA_HYL 3990059
    ip route 141.48.16.0 255.255.255.0 131.47.125.1 100
    ! ISDN备份端口浮动的静态路由,权值为100,旨在当动态路由消失时起作用,建立一条到市局的路由。
    Access-list 101 permit ip any any
    access-list 101 deny eigrp any any
    dialer-list 1 protocol ip list 101
    !进行访问列表控制,将EIGRP协议的hello数据包进行屏蔽。
   
    ● 县局的Cisco 1603
    interface BRI0
    ip address 131.47.126.20 255.255.255.0
    dialer-group 2
    access-list 100 deny eigrp any any
    access-list 100 permit ip any any
    dialer-list 2 protocol ip list 100
    !当动态路由丢失时,响应市局Cisco 3640 的拨号,并自动重新建立到市局的动态路由。进入讨论组讨论。

如果觉得《利用路由备份确保线路贯通》不错,可以推荐给好友哦。


文章关键字:电脑培训学习 - 网络知识 - 网络基础知识,网络基础,计算机网络基础知识,计算机网络知识学习   

与利用路由备份确保线路贯通 相关的文章